summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2018-04-03 13:16:53 +0200
committerAndras Timar <andras.timar@collabora.com>2018-04-12 10:54:36 +0200
commit09670859c352dd360c39e1b1061f8fad3fe133f6 (patch)
treee8f56f0c0598994a6e6ed7185903a1df70426bef /configure.ac
parentf6f1076a6906b6518775e76f282deb9e34b537ee (diff)
configure: check for EGL header if EGL is required
Change-Id: Id7501b9adcd817ce84bfde3a928fe8b4c7e7e01f Reviewed-on: https://gerrit.libreoffice.org/52330 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> (cherry picked from commit e2e3118465411448a3b1f5e56c3456384c009f99) Reviewed-on: https://gerrit.libreoffice.org/52382 Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk> Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com> (cherry picked from commit e336b70550a5615a9b6fd1848c5785fe54c3156a)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bbcc18c77b92..9130c00a1728 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9712,6 +9712,8 @@ if test "x$enable_gtk3" = "xyes"; then
dnl We require egl only for the gtk3 plugin. Otherwise we use glx.
if test "$with_system_epoxy" != "yes"; then
AC_CHECK_LIB(EGL, eglMakeCurrent, [:], AC_MSG_ERROR([libEGL required.]))
+ AC_CHECK_HEADER(EGL/eglplatform.h, [],
+ [AC_MSG_ERROR(EGL headers not found. install mesa-libEGL-devel)], [])
fi
fi
AC_SUBST(GTK3_LIBS)