summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-09-19 22:06:10 +0300
committerAndras Timar <andras.timar@collabora.com>2017-09-28 16:41:02 +0200
commitc1e3d30686772098a704d76ac30f2efc166313ff (patch)
treef0dd14ed1217fe915dd3f663b24e11b5d8a28a7a /configure.ac
parent1e9b00fc82ca484762f0719921670a4ddd06b190 (diff)
Accept macOS 10.13
Change-Id: I9dfc9e8ec6906e0fee4314410d970e02c881e94d Reviewed-on: https://gerrit.libreoffice.org/42869 Reviewed-by: Tor Lillqvist <tml@collabora.com> Tested-by: Tor Lillqvist <tml@collabora.com> (cherry picked from commit 208008c9dd928c9b2ec375594f9a5b66c3f8d9ff)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 7a8ae6e1f085..814f420dd76a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2745,7 +2745,7 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12; do
+ for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11 10.12 10.13; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2779,8 +2779,11 @@ if test $_os = Darwin; then
10.12)
MACOSX_SDK_VERSION=101200
;;
+ 10.13)
+ MACOSX_SDK_VERSION=101300
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--12])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--13])
;;
esac
@@ -2815,8 +2818,11 @@ if test $_os = Darwin; then
10.12)
MAC_OS_X_VERSION_MIN_REQUIRED="101200"
;;
+ 10.13)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--12])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--13])
;;
esac
@@ -2855,8 +2861,11 @@ if test $_os = Darwin; then
10.12)
MAC_OS_X_VERSION_MAX_ALLOWED="101200"
;;
+ 10.13)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101300"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--12])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--13])
;;
esac