summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-12-08 09:29:28 +0200
committerTor Lillqvist <tml@collabora.com>2014-12-08 12:06:07 +0200
commite22526a1852a8986afe8926ac538ea2cb4f2a240 (patch)
treeebf4ff481e65d677fd9d859979927a4b33b66b3b /configure.ac
parent40d11c282cae31bd82e87fd0a0ea54c162e7e53c (diff)
Don't treat clew as part of an "external" clcc module
There is no obvious authoritative upstream for clew anyway, so it causes philosophical problems for distros. For a while, we used to use a zip archive from the "clcc" project on SourceForge that included clew.c and clew.h. (Before that we also just had clew.c and clew.h in our source repo.) So, drop the external/clcc module and have clew.c and clew.h in the source repo again. But this time clew is in a module of its own, not in sc. This re-introduces "No need to have OpenCL optional at configure-time" This reverts commit 764836cb00e8e6dfd2ab48e080a166ec90359e01. Change-Id: I413142f4f9f8399489f9c3e5327132822f07a454 Reviewed-on: https://gerrit.libreoffice.org/13368 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 3 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 9d4e9b24275f..7d6d1d093cd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1096,10 +1096,6 @@ AC_ARG_ENABLE(cairo-canvas,
platforms where Cairo is available.
])
-AC_ARG_ENABLE(opencl,
- AS_HELP_STRING([--disable-opencl],
- [Determines whether to build with OpenCL support.]))
-
AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[Determines whether to enable features that depend on dbus.
@@ -10259,21 +10255,12 @@ dnl =================================================
dnl Check whether to build with OpenCL support.
dnl =================================================
-AC_MSG_CHECKING([whether to build with the OpenCL support.])
-ENABLE_OPENCL=
-
-if test $_os != iOS -a $_os != Android -a "x$enable_opencl" != "xno"; then
- AC_MSG_RESULT([yes])
- # CLCC in BUILD_TYPE tells that we are building a bundled clcc (just the clew part), OPENCL in
- # BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
+if test $_os != iOS -a $_os != Android; then
+ # OPENCL in BUILD_TYPE tells that OpenCL is potentially available on the platform (optional at run-time,
# used through clew).
- BUILD_TYPE="$BUILD_TYPE CLCC OPENCL"
- ENABLE_OPENCL=TRUE
+ BUILD_TYPE="$BUILD_TYPE OPENCL"
AC_DEFINE(HAVE_FEATURE_OPENCL)
-else
- AC_MSG_RESULT([no])
fi
-AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support