summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomofumi Yagi <yagit@mknada.sakura.ne.jp>2014-05-04 11:34:24 +0900
committerMichael Stahl <mstahl@redhat.com>2014-05-05 11:24:17 +0000
commit7623bc31584b38da980016db25fb5dfc702beb10 (patch)
tree90a45b71ee5468b6b1e5eb607923e83399dd49cc /configure.ac
parent4f9b21248ffdf55cef9f3f9d1da76778ee000775 (diff)
fix windows build(external/poppler)
Fix build error on windows with --enable-dbgutil autogen.sh option. We need to link freetype248_D.lib,when we use --enable-dbgutil option. (Suffix "_D" is needed.) Change-Id: Ib2927e777d9b9bb615e1df62e428cf17cc8bc26e Reviewed-on: https://gerrit.libreoffice.org/9248 Tested-by: Michael Stahl <mstahl@redhat.com> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2e4e3b3c5a9f..256efe939f78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10404,7 +10404,8 @@ if test $_os != iOS -a $_os != Android -a $_os != Darwin -a "x$enable_gltf" != "
if test "$test_freetype" = "no"; then
BUILD_TYPE="$BUILD_TYPE FREETYPE"
if test "$COM" = "MSC"; then
- FREETYPE_LIBS="${WORKDIR}/UnpackedTarball/freetype/objs/win32/vc2010/freetype248.lib"
+ test -n "${MSVC_USE_DEBUG_RUNTIME}" && FREETYPE_LIB_DEBUGLIB_SUFFIX="_D"
+ FREETYPE_LIBS="${WORKDIR}/UnpackedTarball/freetype/objs/win32/vc2010/freetype248$FREETYPE_LIB_DEBUGLIB_SUFFIX.lib"
fi
fi
else