summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomáš Chvátal <tomas.chvatal@gmail.com>2015-04-16 10:13:06 +0200
committerAndras Timar <andras.timar@collabora.com>2015-05-19 13:24:30 +0200
commit5af3f7985e51fbd65ed070bb56f27bd7347dc02d (patch)
tree121e05bb64d9900d97abb25d89b01d46a1f4296f /configure.ac
parent970fe67be2f54b5f7aa25615636413e7ae4be3dd (diff)
Make cpp/poppler-version.h header optional
Older popler (SLE11) does not have this header yet. With the code simply if the header not found define version to oldest possible working candidate and also raise the .pc check to the same. Change-Id: I039c879879188fe2eb90cd119b80a1d6354a6a9c Reviewed-on: https://gerrit.libreoffice.org/15339 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3f3863a3d497..5981c28b1752 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10379,14 +10379,15 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
if test "$with_system_poppler" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_POPPLER=TRUE
- PKG_CHECK_MODULES( POPPLER, poppler >= 0.8.0 )
+ PKG_CHECK_MODULES( POPPLER, poppler >= 0.12.0 )
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
save_CPPFLAGS=$CPPFLAGS
CXXFLAGS="$CXXFLAGS $POPPLER_CFLAGS"
CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
- AC_CHECK_HEADER([cpp/poppler-version.h], [],
- [AC_MSG_ERROR([cpp/poppler-version.h not found. Install poppler])], [])
+ AC_CHECK_HEADER([cpp/poppler-version.h],
+ [AC_DEFINE([HAVE_POPPLER_VERSION_H], 1)],
+ [])
CXXFLAGS=$save_CXXFLAGS
CPPFLAGS=$save_CPPFLAGS
AC_LANG_POP([C++])
@@ -10396,6 +10397,7 @@ if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_
AC_MSG_RESULT([internal])
SYSTEM_POPPLER=
BUILD_TYPE="$BUILD_TYPE POPPLER"
+ AC_DEFINE([HAVE_POPPLER_VERSION_H], 1)
fi
else
AC_MSG_RESULT([no])
@@ -12853,6 +12855,7 @@ AC_CONFIG_HEADERS([config_host/config_vcl.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_CONFIG_HEADERS([config_host/config_oauth2.h])
+AC_CONFIG_HEADERS([config_host/config_poppler.h])
AC_OUTPUT
if test "$CROSS_COMPILING" = TRUE; then