summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-08-15 13:25:22 +0200
committerAndras Timar <andras.timar@collabora.com>2014-08-21 21:24:47 +0200
commitec9f786450a43e6a26be9db6efb48f6bbc645894 (patch)
treeb29cf3981e36fa5b00947558f52ddc88e0ded2d5 /configure.ac
parenta92e307d877cc00a908e59b26e70d3a53481aed7 (diff)
configure: don't try to use Win32 make on release branch
Change-Id: Icd8c1b45659ca323aef25a55803f5b1ce078b9d3 Reviewed-on: https://gerrit.libreoffice.org/10932 Reviewed-by: Thomas Arnhold <thomas@arnhold.org> Tested-by: Thomas Arnhold <thomas@arnhold.org> (cherry picked from commit 2087b54aab25ddbab5128af9f777b1686bc0ce5e) Reviewed-on: https://gerrit.libreoffice.org/10990 Reviewed-by: Andras Timar <andras.timar@collabora.com> Tested-by: Andras Timar <andras.timar@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ac2dbd7f8da1..73bc86d6caf0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4847,8 +4847,18 @@ for a in "$MAKE" "$GNUMAKE" make gmake gnumake; do
if test -n "$a"; then
$a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
if test $? -eq 0; then
- GNUMAKE=`which $a`
- break
+ if test "$build_os" = "cygwin"; then
+ if test -n "$($a -v | grep 'Built for Windows')" ; then
+ AC_MSG_NOTICE([$a is a native Win32 make, which is not supported on this old branch.])
+ unset GNUMAKE
+ else
+ GNUMAKE=`which $a`
+ break
+ fi
+ else
+ GNUMAKE=`which $a`
+ break
+ fi
fi
fi
done