summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-11-19 22:04:21 +0200
committerMichael Stahl <michael.stahl@cib.de>2020-12-10 15:29:16 +0100
commitcce4ed9dbb9c6189b07795213aa8731baf22cd2f (patch)
tree86e7a09ea827ce48fed429874cb0453f88a9f26d /configure.ac
parent992c1de725dd7590f63044ce2f1c5337fd271d9a (diff)
Allow --enable-macosx-sandbox without the codesigning identities
For cases where you just want "make test-install" to construct an app bundle that you will manipulate and then sign separately. Change-Id: Iad805618f74ec783ebc013a664f928511b388383 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/106185 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/106260 Tested-by: Jenkins Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107252 Reviewed-by: Michael Stahl <michael.stahl@cib.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8006a535baad..b5c6c049b406 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3094,11 +3094,9 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([whether to sandbox the application])
- if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
- AC_MSG_ERROR([macOS sandboxing requires code signing])
- elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
+ if test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([macOS sandboxing (actually App Store rules) disallows use of Java])
- elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
+ elif test "$enable_macosx_sandbox" = yes; then
ENABLE_MACOSX_SANDBOX=TRUE
AC_DEFINE(HAVE_FEATURE_MACOSX_SANDBOX)
AC_MSG_RESULT([yes])