summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2020-05-28 00:30:18 +0200
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2020-05-28 01:31:51 +0200
commitccd534e31f9522eb29f1d14ffa180e4163094787 (patch)
treee10f4f95acee0ad440acff3d284580884e9eaeec /configure.ac
parent22c51954a28654fde507c341cee28ab85fb9c47f (diff)
Revert "external: bundle box2d"
No need for this extra baggage on the 7.0 branch just yet. This reverts commit a7f2239e649ea1b9ef611d758841584ab51abed0. Change-Id: Ib2e63ea1d48d6b0b930e65ed275725523be9f474 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/95009 Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 113d39f823f9..e950255146bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1961,11 +1961,6 @@ AC_ARG_WITH(system-qrcodegen,
[Use libqrcodegen already on system.]),,
[with_system_qrcodegen="$with_system_libs"])
-AC_ARG_WITH(system-box2d,
- AS_HELP_STRING([--with-system-box2d],
- [Use box2d already on system.]),,
- [with_system_box2d="$with_system_libs"])
-
AC_ARG_WITH(system-mythes,
AS_HELP_STRING([--with-system-mythes],
[Use mythes already on system.]),,
@@ -10259,32 +10254,6 @@ AC_SUBST(QRCODEGEN_CFLAGS)
AC_SUBST(QRCODEGEN_LIBS)
dnl ===================================================================
-dnl Check for system box2d
-dnl ===================================================================
-AC_MSG_CHECKING([which box2d to use])
-if test "$with_system_box2d" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_BOX2D=TRUE
- AC_LANG_PUSH([C++])
- AC_CHECK_HEADER(Box2D/Box2D.h, [],
- [AC_MSG_ERROR(box2d headers not found.)], [])
- AC_CHECK_LIB([Box2D], [main], [:],
- [ AC_MSG_ERROR(box2d library not found.) ], [])
- BOX2D_LIBS=-lBox2D
- AC_LANG_POP([C++])
- BOX2D_CFLAGS=$(printf '%s' "$BOX2D_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
- FilterLibs "${BOX2D_LIBS}"
- BOX2D_LIBS="${filteredlibs}"
-else
- AC_MSG_RESULT([internal])
- SYSTEM_BOX2D=
- BUILD_TYPE="$BUILD_TYPE BOX2D"
-fi
-AC_SUBST(SYSTEM_BOX2D)
-AC_SUBST(BOX2D_CFLAGS)
-AC_SUBST(BOX2D_LIBS)
-
-dnl ===================================================================
dnl Checking for altlinuxhyph
dnl ===================================================================
AC_MSG_CHECKING([which altlinuxhyph to use])