summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2020-06-23 09:22:41 +0300
committerMichael Stahl <michael.stahl@allotropia.de>2021-01-13 10:44:13 +0100
commit9fbbaf11f1b44f241d8a8d819e7de1c98612aa83 (patch)
tree4f2852db4cf954a96553db62d5b4dc2f9d116289 /configure.ac
parent21755f2ab58cc053f9555c3d77241689c225d233 (diff)
Accept iOS SDKs 13.6, 13.7, 14.0, 14.1, 14.2, and 14.3, and macOS SDK 11.1
Several patches from master squashed together. Change-Id: I6c498d0546e20ce1f4353b620e65762c6c87af1a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109165 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 15 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b5c6c049b406..2bc63657d7f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2859,7 +2859,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-11.0 10.15 10.14 10.13}; do
+ for _macosx_sdk in ${with_macosx_sdk-11.1 11.0 10.15 10.14 10.13}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2891,8 +2891,11 @@ if test $_os = Darwin; then
11.0)
MACOSX_SDK_VERSION=110000
;;
+ 11.1)
+ MACOSX_SDK_VERSION=110100
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.0])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.1])
;;
esac
@@ -2951,8 +2954,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MIN_REQUIRED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MIN_REQUIRED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.1])
;;
esac
@@ -3016,8 +3022,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MAX_ALLOWED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MAX_ALLOWED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.1])
;;
esac
@@ -3125,8 +3134,8 @@ dnl ===================================================================
if test $_os = iOS; then
AC_MSG_CHECKING([what iOS SDK to use])
- current_sdk_ver=13.5
- older_sdk_vers="13.4 13.2 13.1 13.0 12.4 12.2"
+ current_sdk_ver=14.3
+ older_sdk_vers="14.2 14.1 14.0 13.7 13.6 13.5 13.4 13.2 13.1 13.0 12.4 12.2"
if test "$enable_ios_simulator" = "yes"; then
platform=iPhoneSimulator
versionmin=-mios-simulator-version-min=12.2