summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Mladek <pmladek@suse.cz>2013-08-29 15:41:59 +0200
committerLuboš Luňák <l.lunak@suse.cz>2013-08-29 14:52:09 +0000
commit8b665b58af200b51ec6d884168d3781899ed5ba0 (patch)
tree3874241fd57af6c72af1e8b990211909f70ea3a8 /configure.ac
parent563d441f9401d8868fae0dc379e9b712019325e7 (diff)
make the tinderbox information more reliable in the about dialog (fdo#58034)
Pass the information via config/config_buildid.h. Then cui/source/dialogs/about.cxx will get rebuilt also in the incremental build. Also allow to set EXTRA_BUILDID also via environment variable. This is much easier with tinderboxed that work with static autogen.input. Change-Id: Ic0b0d13f031c988c096bfd4533e650e245a0ad74 Reviewed-on: https://gerrit.libreoffice.org/5680 Reviewed-by: Luboš Luňák <l.lunak@suse.cz> Tested-by: Luboš Luňák <l.lunak@suse.cz>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 21b68cbf1324..3f685c6d5cc3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11853,15 +11853,17 @@ else
fi
AC_SUBST(STARTCENTER_SPACE_BITMAP)
-EXTRA_BUILDID=
AC_MSG_CHECKING([for extra build ID])
if test -n "$with_extra_buildid" -a "$with_extra_buildid" != "yes" ; then
EXTRA_BUILDID="$with_extra_buildid"
+fi
+# in tinderboxes, it is easier to set EXTRA_BUILDID via the environment variable instead of configure switch
+if test -n "$EXTRA_BUILDID" ; then
AC_MSG_RESULT([$EXTRA_BUILDID])
else
AC_MSG_RESULT([not set])
fi
-AC_SUBST(EXTRA_BUILDID)
+AC_DEFINE_UNQUOTED([EXTRA_BUILDID], ["$EXTRA_BUILDID"])
OOO_VENDOR=
AC_MSG_CHECKING([for vendor])
@@ -12273,6 +12275,7 @@ else
fi
AC_CONFIG_FILES([config_host.mk])
+AC_CONFIG_HEADERS([config/config_buildid.h])
AC_CONFIG_HEADERS([config/config_version.h])
AC_OUTPUT