summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2018-10-31 17:24:28 +0000
committerJan Holesovsky <kendy@collabora.com>2018-12-10 13:01:58 +0100
commit86d9fc6b294513731600d19aead77c1ab5c4a561 (patch)
treef2a6b5c2f756b1d9a298afe8481746a3db13b978 /configure.ac
parent19a3e7e36a9d4f3e2b261e722416125cf6054f34 (diff)
Package separate SVG icon sets
This change packages all SVG based icon sets in seperate zip files. It automatically generates the SVGs links.txt from the non-SVG version, if it doesn't exists by 's/\.png/\.svg/g'. Same for the _dark version, but this just copies it. This would also work for a _dark_svg version, if needed. The patch explicitly does't package sifr_svg and tango_svg. Change-Id: I8d7fda42d0ff9a2108ba8406bd4e82af4c54ff0c Reviewed-on: https://gerrit.libreoffice.org/62706 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 9ebf78da048a..fb9c18df730d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1472,7 +1472,7 @@ AC_ARG_WITH(galleries,
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
- Possible choices: *breeze, *breeze_dark, crystal, *colibre, *elementary, *galaxy, *hicontrast, oxygen, *sifr, *sifr_dark, *tango, tango_testing.]),
+ Possible choices: *breeze, *breeze_dark, *breeze_svg, crystal, *colibre, *colibre_svg, *elementary, *elementary_svg, *galaxy, *hicontrast, oxygen, *sifr, *sifr_dark, *tango, tango_testing.]),
,)
libo_FUZZ_ARG_WITH(helppack-integration,
@@ -11023,7 +11023,7 @@ dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
- with_theme="breeze breeze_dark colibre elementary galaxy hicontrast sifr sifr_dark tango"
+ with_theme="breeze breeze_dark breeze_svg colibre colibre_svg elementary elementary_svg galaxy hicontrast sifr sifr_dark tango"
# test -z "$ENABLE_RELEASE_BUILD" && with_theme="$with_theme tango_testing"
fi
@@ -11031,7 +11031,7 @@ WITH_THEMES=""
if test "x$with_theme" != "xno"; then
for theme in $with_theme; do
case $theme in
- breeze|breeze_dark|crystal|colibre|elementary|galaxy|hicontrast|oxygen|sifr|sifr_dark|tango|tango_testing) real_theme="$theme" ;;
+ breeze|breeze_dark|breeze_svg|crystal|colibre|colibre_svg|elementary|elementary_svg|galaxy|hicontrast|oxygen|sifr|sifr_dark|tango|tango_testing) real_theme="$theme" ;;
default) real_theme=galaxy ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
esac