summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-02-22 09:39:57 +0200
committerAndras Timar <andras.timar@collabora.com>2017-02-24 12:24:44 +0100
commit81f258fc424a1e6890bd8393fcaa5fbd30707071 (patch)
tree1ce0cbc9d4b7c2c081d67b942eb8f3fbc4405190 /configure.ac
parent0e3a3c4626ca535bb72db81463ad73607d9a5025 (diff)
Add --with-package-version option, mainly for non-TDF product macOS builds
For macOS, the "package" version is included in files generated by the build (the Info.plist), so we need to be able to set that at build time, in order to be able to produce differently identified builds from upstream sources with the same upstream package versions. Change-Id: Ieb6b6c07788178b629d6cff0630e30224f6e7ccd (cherry picked from commit b514a0ecdf368e39033c53f312bee7c5e86939e0) Reviewed-on: https://gerrit.libreoffice.org/34540 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Tor Lillqvist <tml@collabora.com> (cherry picked from commit 26079f5d5993ce289f83eee5f1521be0ecb5c59a)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6f9a7b0a2e3..b5149b922997 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,7 +169,13 @@ dnl ===================================================================
dnl Our version is defined by the AC_INIT() at the top of this script.
dnl ===================================================================
-set `echo AC_PACKAGE_VERSION | sed "s/\./ /g"`
+AC_MSG_CHECKING([for package version])
+if test -n "$with_package_version" -a "$with_package_version" != no; then
+ PACKAGE_VERSION="$with_package_version"
+fi
+AC_MSG_RESULT([$PACKAGE_VERSION])
+
+set `echo "$PACKAGE_VERSION" | sed "s/\./ /g"`
LIBO_VERSION_MAJOR=$1
LIBO_VERSION_MINOR=$2
@@ -1417,6 +1423,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+AC_ARG_WITH(package-version,
+ AS_HELP_STRING([--with-package-version='3.1.4.5'],
+ [Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
+,)
+
AC_ARG_ENABLE(ios-simulator,
AS_HELP_STRING([--enable-ios-simulator],
[Build for the iOS Simulator, not iOS device.]),