summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2021-01-28 21:15:02 +0100
committerAdolfo Jayme Barrientos <fitojb@ubuntu.com>2021-01-29 05:17:42 +0100
commitf490652153498b6184c6589263212b3b3326900b (patch)
tree7a947da41201f9d8af7338ff769c4365c22ec14c /configure.ac
parent9fb11584425d692136c3c83d4e02a78432738f6b (diff)
mac: allow cross compiling with host/build x86_64-apple-macos
apple silicon supports to cross compile without special build-tools/full cross-compiling setup, so just always pass the build/host for firebird. firebird and nss don't recognize the -macos specifier, so substitute it by -darwin to make those happy… Change-Id: I953317fc87da2a20dc91acd88c8528796c3b2a69 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/110093 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> (cherry picked from commit 5a0991c9cd60b6ab10fe0665511e7749a0c0ecc2) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/110065 Reviewed-by: Adolfo Jayme Barrientos <fitojb@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 07d56b0785a6..42158d2613b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8360,7 +8360,7 @@ if test -n "$ENABLE_JAVA" -a -z "$JAVAINC"; then
JAVAINC="$JAVAINC -I$JAVA_HOME/include"
;;
- darwin*)
+ darwin*|macos*)
if test -d "$JAVA_HOME/include/darwin"; then
JAVAINC="-I$JAVA_HOME/include -I$JAVA_HOME/include/darwin"
else
@@ -11178,7 +11178,7 @@ elif $GNUCP --version 2>/dev/null | grep "GNU fileutils" >/dev/null 2>/dev/null;
AC_MSG_RESULT([yes])
else
case "$build_os" in
- darwin*|netbsd*|openbsd*|freebsd*|dragonfly*|aix*)
+ darwin*|macos*|netbsd*|openbsd*|freebsd*|dragonfly*|aix*)
x_GNUCP=[\#]
GNUCP=''
AC_MSG_RESULT([no gnucp found - using the system's cp command])