summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-11-19 22:04:21 +0200
committerTor Lillqvist <tml@collabora.com>2020-11-21 16:26:17 +0100
commitaf70b5b8aa7b9dac3b64ef58968208475f673f5c (patch)
treef9fff90e66cd174724563066d2b3fbf4973db621 /configure.ac
parent30b69db070131190454342ce57c25383edf36f04 (diff)
Allow --enable-macosx-sandbox without the codesigning identities
For cases where you just want "make test-install" to construct an app bundle that you will manipulate and then sign separately. Change-Id: Iad805618f74ec783ebc013a664f928511b388383 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/106185 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/106260 Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 976669749ec4..f05df99fc7d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3353,11 +3353,9 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([whether to sandbox the application])
- if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
- AC_MSG_ERROR([macOS sandboxing requires code signing])
- elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
+ if test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([macOS sandboxing (actually App Store rules) disallows use of Java])
- elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
+ elif test "$enable_macosx_sandbox" = yes; then
ENABLE_MACOSX_SANDBOX=TRUE
AC_DEFINE(HAVE_FEATURE_MACOSX_SANDBOX)
AC_MSG_RESULT([yes])