summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2021-03-16 12:21:44 +0200
committerTor Lillqvist <tml@collabora.com>2021-04-05 16:32:44 +0200
commit94919447a79cab8d822f0403dd444b1446db75af (patch)
treefa83369634abdf462891b30a8187a4bebe0aaff5 /configure.ac
parentdea03310cc257514ceaabc732461e9e976ba60ed (diff)
Do build Pdfium for iOS, too
For it to compile, the inclusion of <Carbon/Carbon.h> had to be replaced with <CoreGraphics/CoreGraphics.h>. This fixes the crash in https://github.com/CollaboraOnline/online/issues/1710 . I am not entirely sure yet whether the actual PDF import functionality now then works in the iOS app, though. Change-Id: Ie25e7c58632c0fdddb569d58217f23b26d1e5937 Signed-off-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/112572 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/113604
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4bcf90d63ac5..0a9757aab432 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11616,7 +11616,7 @@ AC_SUBST([ENABLE_DCONF])
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import feature])
ENABLE_PDFIMPORT=
-if test $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_pdfimport" = yes \); then
+if test -z "$enable_pdfimport" -o "$enable_pdfimport" = yes; then
AC_MSG_RESULT([yes])
ENABLE_PDFIMPORT=TRUE
AC_DEFINE(HAVE_FEATURE_PDFIMPORT)