summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-12-15 12:43:29 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2020-12-15 14:39:33 +0100
commit8de620c4c8e33cf75bcec85df189f77483e6a659 (patch)
treed1536fd2429ce4291521e9802203e28a60c15af0 /configure.ac
parent7cb741a86a71481d956296f1d51b5a7543769d26 (diff)
Accept macOS SDK 11.1
Change-Id: Ief4322005fb9087c00f767dcd50a59f2ccbc8a82 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107744 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107749 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 956b16fb313f..4d1729ea7dba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3118,7 +3118,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-11.0 10.15 10.14 10.13}; do
+ for _macosx_sdk in ${with_macosx_sdk-11.1 11.0 10.15 10.14 10.13}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -3150,8 +3150,11 @@ if test $_os = Darwin; then
11.0)
MACOSX_SDK_VERSION=110000
;;
+ 11.1)
+ MACOSX_SDK_VERSION=110100
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.0])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.13--11.1])
;;
esac
@@ -3213,8 +3216,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MIN_REQUIRED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MIN_REQUIRED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.1])
;;
esac
@@ -3275,8 +3281,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MAX_ALLOWED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MAX_ALLOWED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.1])
;;
esac