summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2014-04-17 09:55:57 -0700
committerAndras Timar <andras.timar@collabora.com>2021-03-30 16:33:36 +0200
commit3d60c3f1b3b2430d6f0b07f3f3197150b77d2767 (patch)
tree4277b85c5500d1ed4e4d74659eb0dca401abd2b2 /configure.ac
parent023d5bc3337b414d88396794a6d524c322921db7 (diff)
[cp] Collabora Office versioning
Change-Id: Iff7004808f9637f3dbc6393751246c3a82134487
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b0746dd5304a..1f5111c266e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ dnl in order to create a configure script.
# several non-alphanumeric characters, those are split off and used only for the
# ABOUTBOXPRODUCTVERSIONSUFFIX in openoffice.lst. Why that is necessary, no idea.
-AC_INIT([LibreOffice],[7.1.3.0.0+],[],[],[http://documentfoundation.org/])
+AC_INIT([Collabora Office],[2021.0.0.1],[],[],[https://collaboraoffice.com/])
dnl libnumbertext needs autoconf 2.68, but that can pick up autoconf268 just fine if it is installed
dnl whereas aclocal (as run by autogen.sh) insists on using autoconf and fails hard
@@ -440,15 +440,8 @@ test -n "$LIBO_VERSION_SUFFIX" && LIBO_VERSION_SUFFIX=".$LIBO_VERSION_SUFFIX"
# CFBundleShortVersionString at
# https://developer.apple.com/documentation/bundleresources/information_property_list/cfbundleshortversionstring
-# But that is enforced only in the App Store, and we apparently want to break the rules otherwise.
-
-if test "$enable_macosx_sandbox" = yes; then
- MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.`expr $LIBO_VERSION_MICRO '*' 1000 + $LIBO_VERSION_PATCH`
- MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION
-else
- MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR.$LIBO_VERSION_MICRO.$LIBO_VERSION_PATCH
- MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION$LIBO_VERSION_SUFFIX
-fi
+MACOSX_BUNDLE_SHORTVERSION=$LIBO_VERSION_MAJOR.$LIBO_VERSION_PATCH
+MACOSX_BUNDLE_VERSION=$MACOSX_BUNDLE_SHORTVERSION
AC_SUBST(LIBO_VERSION_MAJOR)
AC_SUBST(LIBO_VERSION_MINOR)
@@ -471,7 +464,7 @@ dnl ===================================================================
dnl Product version
dnl ===================================================================
AC_MSG_CHECKING([for product version])
-PRODUCTVERSION="$LIBO_VERSION_MAJOR.$LIBO_VERSION_MINOR"
+PRODUCTVERSION="$LIBO_VERSION_MAJOR.$LIBO_VERSION_PATCH"
AC_MSG_RESULT([$PRODUCTVERSION])
AC_SUBST(PRODUCTVERSION)