summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2021-06-09 13:41:30 +0100
committerAndras Timar <andras.timar@collabora.com>2021-06-14 08:08:31 +0200
commit3cd5c94d82410481ce31b65a439c67d1c37497df (patch)
tree5b74f5964244044edf33f792af5c2a28d4cbe963 /configure.ac
parentde92ce01922ec3df1d8ab83530856d53453cb7e2 (diff)
allow system firebird 4
drop odb load tests of experimental era odbs that only contain fdb and not fbk, that ends up only proving that was a bad idea which we know so that's why we stopped doing it this squashed commit contains... HAVE_FIREBIRD_30 is not used anymore Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116977 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> and... drop firebird test of initial experimental period fdb-only format Initially when the firebird embedded database support was first experimental we saved the fdb firebird file format. A test was added by 3f114eb4a2f3994b980aa607f2d4afc58e5aaa1d around then (2013) to test loading firebird odbs Then with commit de899f0b350e51b1932fa4674f7ce2ae386cd1ce Date: Thu Jun 2 11:56:10 2016 +0200 connectivity: firebird: use ODS12 test database for Firebird 3 if building with firebird 3 a replacement odb was created in firebird 3.X ODS12 format to use instead of the 2.X ODS11 file. Those fdb file formats were endian specific and database version specific. Which was a well known problem documented in tdf#72987 and a blocker for leaving 'experimental' at that point in time. So finally with commit 0cc1ddf2d8d6bc7df74fdd8f8f97381df681177d Date: Thu Aug 11 12:02:56 2016 +0200 tdf#72987 GSoC Use Firebird backup format the save was changed to save the backup fbk file format and load restores the database from that fbk file format (2016) when available. later in commit 860ecb9e583627ab43097784ad98b41afd983ff6 Date: Thu Jan 5 12:58:26 2017 +0100 require firebird 3.0 for build (don't allow 2.5) the firebird 2.X (ODS11) test of loading the fdb format was dropped leaving just the firebird 3.X (ODS12) fdb case because firebird 3.X cannot directly load the ODS11 format Now with the appearance of firebird 4 the same problem arises that firebird doesn't load older binary formats directly. In the end all we established here is that an odb containing only a fdb is endian and version specific and a bad idea wrt compatibility so we shouldn't do that. But we knew that, so embedded firebird databases were an experiemental curosity until 0cc1ddf2d8d6bc7df74fdd8f8f97381df681177d enabled use of the fbk format. We're not gaining anything with the test of loading the binary only case because we know that's an unsustainable route we abandoned. Change-Id: I330065f61d2d0fdfeeaeba4ee2e739e222d1c665 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116895 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4ad5a31d76ef..cef4e660221c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9923,11 +9923,10 @@ if test "$enable_firebird_sdbc" = "yes" ; then
AC_MSG_CHECKING([Firebird version])
if test -n "${FIREBIRD_VERSION}"; then
FIREBIRD_MAJOR=`echo $FIREBIRD_VERSION | cut -d"." -f1`
- FIREBIRD_MINOR=`echo $FIREBIRD_VERSION | cut -d"." -f2`
- if test "$FIREBIRD_MAJOR" -eq "3" -a "$FIREBIRD_MINOR" -eq "0"; then
+ if test "$FIREBIRD_MAJOR" -ge "3"; then
AC_MSG_RESULT([OK])
else
- AC_MSG_ERROR([Ensure firebird 3.0.x is installed])
+ AC_MSG_ERROR([Ensure firebird >= 3 is installed])
fi
else
save_CFLAGS="${CFLAGS}"
@@ -9948,7 +9947,6 @@ int fb_api_is_30(void) { return 0; }
AC_MSG_RESULT([none])
else
dnl Embedded Firebird has version 3.0
- AC_DEFINE(HAVE_FIREBIRD_30, 1)
dnl We need libatomic_ops for any non X86/X64 system
if test "${CPUNAME}" != INTEL -a "${CPUNAME}" != X86_64; then
dnl ===================================================================