summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndras Timar <andras.timar@collabora.com>2018-04-23 16:41:51 +0200
committerAndras Timar <andras.timar@collabora.com>2021-03-30 16:33:37 +0200
commit39632d33120e7c674574511d37e3666453ff6642 (patch)
treee40449dcc624762d1261f1b3dd50def98ac7b87f /configure.ac
parent39bd6dc199df3757b0e7b7f19772bb4410c8fa78 (diff)
[cp] Optionally bundle even more Google Noto fonts
Change-Id: I6c08476710ab541ff9b9407f5d874dbb038990df
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 35b0affa02e9..63322d9f19ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1924,6 +1924,11 @@ libo_FUZZ_ARG_WITH(fonts,
known to be available on the system then you should use this option.]),
,)
+AC_ARG_ENABLE(noto-font,
+ AS_HELP_STRING([--enable-noto-font],
+ [Add more Google Noto fonts.]),
+,)
+
AC_ARG_WITH(epm,
AS_HELP_STRING([--with-epm],
[Decides which epm to use. Default is to use the one from the system if
@@ -12731,6 +12736,19 @@ else
fi
AC_SUBST(WITH_FONTS)
+dnl Test whether to include more Google Noto fonts
+dnl ===================================================================
+AC_MSG_CHECKING([whether to include more Google Noto fonts])
+if test "$enable_noto_font" = "" -o "$enable_noto_font" = "no" -o "$with_fonts" = "no"; then
+ AC_MSG_RESULT([no])
+ WITH_NOTO_FONT=
+else
+ AC_MSG_RESULT([yes])
+ WITH_NOTO_FONT=TRUE
+ BUILD_TYPE="$BUILD_TYPE NOTO_FONT"
+ SCPDEFS="$SCPDEFS -DWITH_NOTO_FONT"
+fi
+AC_SUBST(WITH_NOTO_FONT)
dnl ===================================================================
dnl Test whether to enable online update service