summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2020-12-22 09:29:13 +0100
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2021-02-07 12:56:43 +0100
commit2462947feb8d56e8eb576c2071e3642e730d360e (patch)
tree75d09f663075d67f8cacd58bbd0bc88d7783514a /configure.ac
parentb6f74722173b0384efa6798799b83807e9f0d814 (diff)
That wasn't a reliable way to detect Apple JDK
The check had been introduced with 16c0807d75cfd9ecbca9c703ed0eadda80529aab "configure: reject Apple JDK", but with 7db048f62929a9d267b63db3a6ea2b58b47ec757 "Manually select JDK outside /Library/Java/JavaVirtualMachines on macOS" it works fine to configure --with-jdk-home= a (non-Apple) JDK installed outside /Library/Java/JavaVirtualMachines. If anybody thinks a check to reject Apple JDK would still be useful, and knows a reliable way to detect it, feel free to add back a fixed check. Change-Id: I18910d992e3d1fc6fd8fc4b9d522aec0cce3e652 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108144 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> (cherry picked from commit 8ba7c3b63f87a443139c9104b02e3864dd31daf9) Reviewed-on: https://gerrit.libreoffice.org/c/core/+/110438 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 6a74bd3c6060..cf7d10dc01de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8275,13 +8275,6 @@ _ACEOF
# now check if $JAVA_HOME is really valid
if test "$_os" = "Darwin" -o "$OS_FOR_BUILD" = MACOSX; then
- case "${JAVA_HOME}" in
- /Library/Java/JavaVirtualMachines/*)
- ;;
- *)
- AC_MSG_ERROR([JDK in $JAVA_HOME cannot be used in CppUnit tests - install Oracle JDK])
- ;;
- esac
if test ! -f "$JAVA_HOME/lib/jvm.cfg" -a "x$with_jdk_home" = "x"; then
AC_MSG_WARN([JAVA_HOME was not explicitly informed with --with-jdk-home. the configure script])
AC_MSG_WARN([attempted to find JAVA_HOME automatically, but apparently it failed])