summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorRĂ¼diger Timm <rt@openoffice.org>2008-08-27 12:55:44 +0000
committerRĂ¼diger Timm <rt@openoffice.org>2008-08-27 12:55:44 +0000
commite545969cb155da6cd1bf08146b0a61d074551f22 (patch)
treea15f5f8d4ae052ab30c5d372b6b7ca29a89816a5 /config_office/configure.in
parent4ca3e88603fb30c38226749949d666590d77d63c (diff)
INTEGRATION: CWS sb91 (1.275.2); FILE MERGED
2008/07/17 15:25:31 sb 1.275.2.1: #i91721# added explicit ENABLE_GCONF (had previously been covered by ENABLE_GNOMEVFS, but unxsolu4 does not support the latter but does support the former)
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in26
1 files changed, 23 insertions, 3 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index e2a970f08cf1..63f37033ac0e 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2008-08-19 12:03:26 $
+dnl * Date: $Date: 2008-08-27 13:55:44 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.285 $ )
+AC_REVISION( $Revision: 1.286 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -212,6 +212,9 @@ AC_ARG_ENABLE(dbus,
[ --enable-dbus Determines whether to enable presentation mode
screensaver control under GNOME via DBUS
],,enable_dbus=no)
+AC_ARG_ENABLE(gconf,
+[ --disable-gconf Determines whether to use the GConf support
+],,enable_gconf=yes)
AC_ARG_ENABLE(gnome-vfs,
[ --disable-gnome-vfs Determines whether to use the Gnome Virtual Filing
System on platforms where that VFS is available
@@ -5225,6 +5228,21 @@ else
fi
dnl ===================================================================
+dnl GCONF check
+dnl ===================================================================
+
+ENABLE_GCONF=""
+AC_MSG_CHECKING([whether to enable GConf support])
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gconf" = "yes"; then
+ ENABLE_GCONF="TRUE"
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES( GCONF, gconf-2.0 )
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_GCONF)
+
+dnl ===================================================================
dnl Gnome VFS check
dnl ===================================================================
@@ -5234,7 +5252,9 @@ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gnome_vfs" = "yes";
ENABLE_GNOMEVFS="TRUE"
AC_MSG_RESULT([yes])
PKG_CHECK_MODULES( GNOMEVFS, gnome-vfs-2.0 >= 2.6.0 )
- PKG_CHECK_MODULES( GCONF, gconf-2.0 )
+ if test "$ENABLE_GCONF" != "TRUE"; then
+ PKG_CHECK_MODULES( GCONF, gconf-2.0 )
+ fi
else
AC_MSG_RESULT([no])
fi