summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorIvo Hinkelmann <ihi@openoffice.org>2008-04-24 16:04:35 +0000
committerIvo Hinkelmann <ihi@openoffice.org>2008-04-24 16:04:35 +0000
commitb2aa742febb4409c995851ec1fa129f8aaba010c (patch)
tree31a88f2e95b26f14855ca106f5c590fb922d6df1 /config_office/configure.in
parent08bab323d555b55b73d964c98ffa29378d45e4b3 (diff)
INTEGRATION: CWS cmcfixes43 (1.249.12); FILE MERGED
2008/03/25 11:59:49 cmc 1.249.12.6: #i86670# tweak for gentoo locations 2008/03/20 16:59:44 cmc 1.249.12.5: #i86670# how about this then for the sdkdir fallback 2008/03/12 10:59:41 cmc 1.249.12.4: RESYNC: (1.249-1.252); FILE MERGED 2008/03/10 12:21:09 cmc 1.249.12.3: #i86874# add a system lpsolve option 2008/03/06 09:46:31 cmc 1.249.12.2: #i86715# add a --with-system-headers 2008/03/04 08:52:09 cmc 1.249.12.1: #i86670# add support for libxul
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in112
1 files changed, 86 insertions, 26 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index 30317cbbd898..1cdf8e33ac1c 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2008-04-15 11:56:42 $
+dnl * Date: $Date: 2008-04-24 17:04:35 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.263 $ )
+AC_REVISION( $Revision: 1.264 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -276,9 +276,15 @@ AC_ARG_WITH(writer2latex,
],,)
AC_ARG_WITH(system-libs,
[ --with-system-libs Use libs already on system -- enables all
- --with-system-* flags except mozilla, python and
+ --with-system-* flags except mozilla and
odbc/sane/xrender-header(s)
],,)
+AC_ARG_WITH(system-headers,
+[ --with-system-headers Use headers already on system -- enables all
+ --with-system-* flags for external packages
+ whose headers are the only entities used i.e.
+ boost/vigra/odbc/sane/xrender-header(s)
+],,)
AC_ARG_WITH(system-jars,
[ --without-system-jars When building with --with-system-libs, also the
needed jars are expected on the system. Use this to
@@ -482,12 +488,16 @@ AC_ARG_WITH(system-mythes,
AC_ARG_WITH(system-altlinuxhyph,
[ --with-system-altlinuxhyph Use ALTLinuxhyph already on system
],,)
+AC_ARG_WITH(system-lpsolve,
+[ --with-system-lpsolve Use lpsolve already on system
+],,)
AC_ARG_WITH(system-mozilla,
[ --with-system-mozilla Use mozilla already on system. Note that some
components cannot be built against a contemporary
mozilla. The flavour used can be specified by
--with-system-mozilla=<flavour>. Supported are:
- xulrunner (default), firefox, seamonkey, mozilla
+ libxul (default), xulrunner, firefox, seamonkey,
+ mozilla
], WITH_SYSTEM_MOZILLA=$withval, WITH_SYSTEM_MOZILLA=no)
AC_ARG_WITH(stlport,
[ --with-stlport The location that STLport is installed in. The STL
@@ -3279,10 +3289,12 @@ fi
dnl ===================================================================
dnl Check for prelinked libgcc_s.so.1
dnl ===================================================================
-if test -n "$checkforprelink" -a -f /etc/rpm/macros.prelink; then
- with_system_stdlibs=yes
- AC_MSG_WARN([prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
- echo "prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
+if test -z "$with_system_stdlibs" -a -z "$with_system_libs"; then
+ if test -n "$checkforprelink" -a -f /etc/rpm/macros.prelink; then
+ with_system_stdlibs=yes
+ AC_MSG_WARN([prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
+ echo "prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
+ fi
fi
dnl ===================================================================
@@ -3491,7 +3503,8 @@ if test "$_os" = "Darwin" && test "$with_system_python" != "no"; then
with_system_python=yes
fi
AC_MSG_CHECKING([which python to use])
-if test -n "$with_system_python" && test "$with_system_python" != "no"; then
+if test -n "$with_system_python" -o -n "$with_system_libs" && \
+ test "$with_system_python" != "no"; then
SYSTEM_PYTHON=YES
AC_MSG_RESULT([external])
AM_PATH_PYTHON([2.2])
@@ -3799,7 +3812,8 @@ dnl ===================================================================
dnl Check for system boost
dnl ===================================================================
AC_MSG_CHECKING([which boost to use])
-if test -n "$with_system_boost" && test "$with_system_boost" != "no"; then
+if test -n "$with_system_boost" -o -n "$with_system_headers" && \
+ test "$with_system_boost" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_BOOST=YES
AC_LANG_PUSH([C++])
@@ -3819,7 +3833,8 @@ dnl ===================================================================
dnl Check for system vigra
dnl ===================================================================
AC_MSG_CHECKING([which vigra to use])
-if test -n "$with_system_vigra" && test "$with_system_vigra" != "no"; then
+if test -n "$with_system_vigra" -o -n "$with_system_headers" && \
+ test "$with_system_vigra" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_VIGRA=YES
AC_LANG_PUSH([C++])
@@ -3837,7 +3852,8 @@ dnl ===================================================================
dnl Check for system odbc
dnl ===================================================================
AC_MSG_CHECKING([which odbc headers to use])
-if test -n "$with_system_odbc_headers" && test "$with_system_odbc_headers" != "no"; then
+if test -n "$with_system_odbc_headers" -o -n "$with_system_headers" && \
+ test "$with_system_odbc_headers" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_ODBC_HEADERS=YES
@@ -3924,7 +3940,9 @@ if test -n "$with_system_mozilla" && test "$with_system_mozilla" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_MOZILLA=YES
AC_MSG_CHECKING([which Mozilla flavour to use])
- if test -n "$with_system_mozilla" && test "$with_system_mozilla" = "xulrunner"; then
+ if test -n "$with_system_mozilla" && test "$with_system_mozilla" = "libxul"; then
+ MOZ_FLAVOUR=libxul
+ elif test -n "$with_system_mozilla" && test "$with_system_mozilla" = "xulrunner"; then
MOZ_FLAVOUR=xulrunner
elif test -n "$with_system_mozilla" && test "$with_system_mozilla" = "seamonkey"; then
MOZ_FLAVOUR=seamonkey
@@ -3933,12 +3951,18 @@ if test -n "$with_system_mozilla" && test "$with_system_mozilla" != "no"; then
elif test -n "$with_system_mozilla" && test "$with_system_mozilla" = "mozilla"; then
MOZ_FLAVOUR=mozilla
else
- MOZ_FLAVOUR=xulrunner
+ MOZ_FLAVOUR=libxul
fi
tmp=`echo $MOZ_FLAVOUR | $PERL -e 'print ucfirst(<STDIN>);'`
AC_MSG_RESULT($tmp)
- PKG_CHECK_MODULES( MOZILLAXPCOM, $MOZ_FLAVOUR-xpcom )
+ PKG_CHECK_MODULES( MOZ_NSS, nss, STANDALONENSS="TRUE", STANDALONENSS="" )
+ if test -z "$STANDALONENSS"; then
+ PKG_CHECK_MODULES( MOZ_NSS, $MOZ_FLAVOUR-nss )
+ else
+ NSS_LIB="-L`$PKG_CONFIG --variable=libdir nss`"
+ AC_SUBST(NSS_LIB)
+ fi
if $PKG_CONFIG --exists nspr ; then
PKG_CHECK_MODULES( MOZ_NSPR, nspr )
@@ -3948,12 +3972,20 @@ if test -n "$with_system_mozilla" && test "$with_system_mozilla" != "no"; then
PKG_CHECK_MODULES( MOZ_NSPR, $MOZ_FLAVOUR-nspr )
fi
- PKG_CHECK_MODULES( MOZ_NSS, nss, STANDALONENSS="TRUE", STANDALONENSS="" )
- if test -z "$STANDALONENSS"; then
- PKG_CHECK_MODULES( MOZ_NSS, $MOZ_FLAVOUR-nss )
+ if $PKG_CONFIG --exists libxul ; then
+ PKG_CHECK_MODULES( MOZILLAXPCOM, libxul )
+ MOZ_INC=`$PKG_CONFIG --variable=includedir libxul`
+ MOZ_LIB=`$PKG_CONFIG --variable=libdir libxul`
+ if ! test -e "$MOZ_LIB/libxul.so"; then
+ MOZ_LIB=`$PKG_CONFIG --variable=sdkdir libxul`
+ if test -e "$MOZ_LIB/sdk/lib/libxul.so"; then
+ MOZ_LIB="$MOZ_LIB/sdk/lib"
+ fi
+ fi
else
- NSS_LIB="-L`$PKG_CONFIG --variable=libdir nss`"
- AC_SUBST(NSS_LIB)
+ PKG_CHECK_MODULES( MOZILLAXPCOM, $MOZ_FLAVOUR-xpcom )
+ MOZ_INC=`$PKG_CONFIG --variable=includedir $MOZ_FLAVOUR-xpcom`
+ MOZ_LIB=`$PKG_CONFIG --variable=libdir $MOZ_FLAVOUR-xpcom`
fi
save_CPPFLAGS="$CPPFLAGS"
@@ -3969,8 +4001,6 @@ Fixed since nss 3.9.3 (contained by e.g. mozilla >= 1.7.5))], [])
CPPFLAGS="$save_CPPFLAGS"
LIBS="$save_LIBS"
- MOZ_INC=`$PKG_CONFIG --variable=includedir $MOZ_FLAVOUR-xpcom`
- MOZ_LIB=`$PKG_CONFIG --variable=libdir $MOZ_FLAVOUR-xpcom`
MOZ_LIB_XPCOM=$MOZILLAXPCOM_LIBS
if test "$WITH_LDAP" != "NO" && test "$WITH_OPENLDAP" != "YES"; then
AC_MSG_CHECKING([whether $tmp was compiled with --enable-ldap])
@@ -3983,6 +4013,13 @@ Could not find LDAP header include files in $MOZ_INC/ldap.
Please recompile $tmp with --enable-ldap or use --with-openldap.])
fi
fi
+
+ #e.g. http://fedoraproject.org/wiki/Releases/FeatureXULRunnerAPIChanges
+ #the plugin pkg-config etc. reverts to "mozilla-plugin" with libxul
+ if test "$MOZ_FLAVOUR" == "libxul"; then
+ MOZ_FLAVOUR="mozilla"
+ fi
+
elif test "$enable_mozilla" = "no"; then
AC_MSG_RESULT([none])
WITH_MOZILLA=NO
@@ -4119,7 +4156,8 @@ dnl ===================================================================
dnl Check for system sane
dnl ===================================================================
AC_MSG_CHECKING([which sane header to use])
-if test -n "$with_system_sane_header" && test "$with_system_sane_header" != "no"; then
+if test -n "$with_system_sane_header" -o -n "$with_system_headers" && \
+ test "$with_system_sane_header" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_SANE_HEADER=YES
AC_CHECK_HEADER(sane/sane.h, [],
@@ -4316,7 +4354,8 @@ else
XRENDER_LINK=NO
fi
AC_MSG_CHECKING([which Xrender headers to use])
-if test -n "$with_system_xrender_headers" && test "$with_system_xrender_headers" != "no"; then
+if test -n "$with_system_xrender_headers" -o -n "$with_system_headers" && \
+ test "$with_system_xrender_headers" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_XRENDER_HEADERS=YES
AC_CHECK_HEADER(X11/extensions/Xrender.h, [],
@@ -4450,7 +4489,8 @@ dnl ===================================================================
dnl Check for system hunspell
dnl ===================================================================
AC_MSG_CHECKING([which libhunspell to use])
-if test -n "$with_system_hunspell" && test "$with_system_hunspell" != "no"; then
+if test -n "$with_system_hunspell" -o -n "$with_system_libs" && \
+ test "$with_system_hunspell" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_HUNSPELL=YES
AC_LANG_PUSH([C++])
@@ -4478,7 +4518,8 @@ dnl ===================================================================
dnl Checking for altlinuxhyph
dnl ===================================================================
AC_MSG_CHECKING([which altlinuxhyph to use])
-if test -n "$with_system_altlinuxhyph" && test "$with_system_altlinuxyph" != "no"; then
+if test -n "$with_system_altlinuxhyph" -o -n "$with_system_libs" && \
+ test "$with_system_altlinuxhyph" != "no"; then
AC_MSG_RESULT([external])
SYSTEM_HYPH=YES
AC_CHECK_HEADER(hyphen.h, [],
@@ -4520,6 +4561,25 @@ else
fi
AC_SUBST(SYSTEM_MYTHES)
+dnl ===================================================================
+dnl Checking for lpsolve
+dnl ===================================================================
+AC_MSG_CHECKING([which lpsolve to use])
+if test -n "$with_system_lpsolve" -o -n "$with_system_libs" && \
+ test "$with_system_lpsolve" != "no"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_LPSOLVE=YES
+ AC_CHECK_HEADER(lpsolve/lp_lib.h, [],
+ [ AC_MSG_ERROR(lpsolve headers not found.)], [])
+ AC_CHECK_LIB(lpsolve55, make_lp, ,
+ [ AC_MSG_ERROR(lpsolve library not found or too old.)], [])
+else
+ AC_MSG_RESULT([internal])
+ SYSTEM_LPSOLVE=NO
+ BUILD_TYPE="$BUILD_TYPE LPSOLVE"
+fi
+AC_SUBST(SYSTEM_LPSOLVE)
+
dnl ***************************************
dnl testing libc version for Linux...
dnl ***************************************