summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2013-05-13 07:53:52 +0200
committerLionel Elie Mamane <lionel@mamane.lu>2013-05-13 07:56:03 +0200
commitca8201ef54cd58e41504dc04101aa76c97a78733 (patch)
treeb5c3c89ed89f5a1d96138c4f31671f7e3fc10689
parent4af1a4a0865d91494c3197fc862bf3b7c49f3990 (diff)
configure.ac: fix error message on non-MacOS X builds
Change-Id: I33c0b7218054d8d879d72a2a47899b39ae8458ca
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a2f14282fb9..efa1b777e7db 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8646,7 +8646,7 @@ DISABLE_OPENSSL="NO"
AC_MSG_CHECKING([whether to disable OpenSSL usage])
if test "$enable_openssl" = "yes"; then
AC_MSG_RESULT([no])
- if test $_os = Darwin -a $MAC_OS_X_VERSION_MIN_REQUIRED -ge 1070; then
+ if test "$_os" = Darwin -a "${MAC_OS_X_VERSION_MIN_REQUIRED:-0}" -ge 1070; then
# OpenSSL is deprecated when building for 10.7 or later.
#
# http://stackoverflow.com/questions/7406946/why-is-apple-deprecating-openssl-in-macos-10-7-lion