summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stahl <Michael.Stahl@cib.de>2019-07-31 12:30:26 +0200
committerSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2019-11-29 07:51:49 +0100
commit436a9631310422c4549ff6c21af80b0248c2779f (patch)
tree9b3dd58ff7cd431f77f3a21c1af12c957b956667
parent01fe2d57103faf6b845ad83d50336db234460dd7 (diff)
solenv installer: don't let RPM generate config(...) Requires
Fedora 30's rpm 4.14.2.1 will generate this Requires: config(lodevbasis6.1-core) = 6.1.7.0.0-1 ... but no corresponding Provides because that's disabled, so the package cannot be installed. The reason is that there is one %config file in the -core rpm: %attr(0644,root,root) %config(noreplace) "/opt/libreofficedev6.1/./share/psprint/psprint.conf" Old RPM from CentOS6 does not generate these config requires. Unfortunately there doesn't appear to be a way to disable this config(...) without disabling AutoReq, so do that, and invoke the shell script find-requires-x11.sh manually from epmfile.pm. Change-Id: I7fee0d9cd1b9e79f81bd4c611500e84736564881 Reviewed-on: https://gerrit.libreoffice.org/76736 Tested-by: Jenkins Reviewed-by: Michael Stahl <Michael.Stahl@cib.de> (cherry picked from commit b1d555ed42a035e0489accc19903c1ed8897bcee) (cherry picked from commit fa58f27bb421b449134e79c03a4fb8762ab18679) (cherry picked from commit fe51efc58dc04746282aaf641b5e4bd240d20da5)
-rw-r--r--solenv/bin/modules/installer/epmfile.pm12
1 files changed, 6 insertions, 6 deletions
diff --git a/solenv/bin/modules/installer/epmfile.pm b/solenv/bin/modules/installer/epmfile.pm
index 0dbc37a92cb9..fce17518aa76 100644
--- a/solenv/bin/modules/installer/epmfile.pm
+++ b/solenv/bin/modules/installer/epmfile.pm
@@ -1193,15 +1193,15 @@ sub set_autoprovreq_in_specfile
{
my ($changefile, $findrequires, $bindir) = @_;
- my $autoreqprovline;
+ my $autoreqprovline = "AutoReqProv\: no\n";
if ( $findrequires )
{
- $autoreqprovline = "AutoProv\: no\n%define _use_internal_dependency_generator 0\n%define __find_requires $bindir/$findrequires\n";
- }
- else
- {
- $autoreqprovline = "AutoReqProv\: no\n";
+ # don't let rpm invoke it, we never want to use AutoReq because
+ # rpm will generate Requires: config(packagename)
+ open (FINDREQUIRES, "echo | $bindir/$findrequires |");
+ while (<FINDREQUIRES>) { $autoreqprovline .= "Requires: $_\n"; }
+ close (FINDREQUIRES);
}
$autoreqprovline .= "%define _binary_filedigest_algorithm 1\n%define _binary_payload w9.gzdio\n";