summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2015-06-09 00:33:38 +0300
committerAndras Timar <andras.timar@collabora.com>2015-10-02 14:58:37 +0200
commit5d096341f7318c69eb557dcfcf4f95e0b4b77463 (patch)
treefe75f896bef71ce30a134acc3f38bfae56821886
parent6d82539be0f72aa4308aad5c31cc6f6b66e73134 (diff)
accept OS X 10.11 in configure, and fix firebird build against it
Accept also OS X 10.11 Change-Id: Ieedf4810f1e726bf11f0d0b1a203e560a0b16550 (cherry picked from commit bcd52844597640504d3a7caf5441f9f6181497c5) Fix Firebird build against OS X SDK 10.11 Change-Id: I60c7540241c41f5063736f2a3d4817371411c8dc (cherry picked from commit a799d7c9a66464f33bd8ee42d535e29a976d64ae) Reviewed-on: https://gerrit.libreoffice.org/18718 Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
-rw-r--r--configure.ac17
-rw-r--r--external/firebird/firebird-macosx.patch.19
2 files changed, 22 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f2a7271cd124..0d0e9969ca4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2737,7 +2737,7 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([what Mac OS X SDK to use])
- for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10; do
+ for _macosx_sdk in $with_macosx_sdk 10.8 10.9 10.10 10.11; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2765,8 +2765,11 @@ if test $_os = Darwin; then
10.10)
MACOSX_SDK_VERSION=101000
;;
+ 10.11)
+ MACOSX_SDK_VERSION=101100
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--10])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.8--11])
;;
esac
@@ -2795,8 +2798,11 @@ if test $_os = Darwin; then
10.10)
MAC_OS_X_VERSION_MIN_REQUIRED="101000"
;;
+ 10.11)
+ MAC_OS_X_VERSION_MIN_REQUIRED="101100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--10])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.8--11])
;;
esac
@@ -2829,8 +2835,11 @@ if test $_os = Darwin; then
10.10)
MAC_OS_X_VERSION_MAX_ALLOWED="101000"
;;
+ 10.11)
+ MAC_OS_X_VERSION_MAX_ALLOWED="101100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--10])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.8--11])
;;
esac
diff --git a/external/firebird/firebird-macosx.patch.1 b/external/firebird/firebird-macosx.patch.1
index 0ad9bd90452a..42007d50a38f 100644
--- a/external/firebird/firebird-macosx.patch.1
+++ b/external/firebird/firebird-macosx.patch.1
@@ -27,6 +27,15 @@
PLATFORM_POSTBUILD_TARGET=darwin_postbuild_target
+@@ -57,7 +57,7 @@
+
+ LINK_TRACE = $(LIB_LINK) $(LIB_BUNDLE_OPTIONS)
+
+-LINK_CLIENT = $(LIB_LINK) -nodefaultlibs $(LINK_FIREBIRD_CLIENT_SYMBOLS) $(LIB_LINK_OPTIONS) $(LIB_LINK_IMPLIB)\
++LINK_CLIENT = $(LIB_LINK) $(LINK_FIREBIRD_CLIENT_SYMBOLS) $(LIB_LINK_OPTIONS) $(LIB_LINK_IMPLIB)\
+ $(LIB_CLIENT_LINK_OPTIONS) $(LIB_LINK_SONAME)
+
+ ifeq (@VOID_PTR_SIZE@,8)
diff -ur firebird.org/builds/posix/postfix.darwin firebird/builds/posix/postfix.darwin
--- firebird.org/builds/posix/postfix.darwin 2013-07-12 20:55:46.000000000 +0200
+++ firebird/builds/posix/postfix.darwin 2013-07-15 12:07:36.000000000 +0200