summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@hadrons.org>2013-10-21 05:07:56 +0200
committerGuillem Jover <guillem@hadrons.org>2013-10-21 05:35:44 +0200
commitf41fdcf186abbe26b11ba10fb3d4d0c1f109501e (patch)
tree37360497802bbb330e969559e9323f722d423dfa /configure.ac
parent86cbff385a756f428091441674a5867603b1c910 (diff)
Add funopen() function
This is a wrapper over the glibc fopencookie() function. We diverge from the FreeBSD, OpenBSD and DragonFlyBSD declarations, because seekfn() there wrongly uses fpos_t, assuming it's an integral type, and any code using that on a system where fpos_t is a struct (such as GNU-based systems or NetBSD) will fail to build. In which case, as the code has to be modified anyway, we might just as well use the correct declaration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ad5fa25..1c1b962 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,7 +124,7 @@ AC_LINK_IFELSE(
AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])])
-AC_CHECK_FUNCS([clearenv dirfd __fpurge getexecname getline sysconf])
+AC_CHECK_FUNCS([clearenv dirfd fopencookie __fpurge getexecname getline sysconf])
AC_CONFIG_FILES([
Makefile