summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@hadrons.org>2017-01-10 04:33:15 +0100
committerGuillem Jover <guillem@hadrons.org>2017-06-05 05:52:07 +0200
commitd6c35f618c4f3ca20a43a5a28e08cde3540e6b7c (patch)
tree1411cee5d5efbde2ff96f3d0fa508768f693b1d7 /configure.ac
parentdb7470b048a14bdc69a34fbd192ec626e1786411 (diff)
Do not provide funopen() on musl
Fixes: https://bugs.debian.org/818246
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5cbc2fa..e4d190d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,7 +51,11 @@ AS_CASE([$host_os],
AC_SEARCH_LIBS([clock_gettime], [rt], [CLOCK_GETTIME_LIBS="-lrt"])
AC_SUBST([CLOCK_GETTIME_LIBS])
LIBS="$saved_LIBS"
- ]
+ ],
+ [*-musl], [
+ # Upstream refuses to define this, we will do it ourselves then.
+ AC_DEFINE([__MUSL__], [1], [Define to 1 if we are building for musl])
+ ],
)
# Checks for header files.