summaryrefslogtreecommitdiff
path: root/libs/gst/helpers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libs/gst/helpers/Makefile.am')
-rw-r--r--libs/gst/helpers/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/libs/gst/helpers/Makefile.am b/libs/gst/helpers/Makefile.am
index d2df0e2a0e..ca46fd67d7 100644
--- a/libs/gst/helpers/Makefile.am
+++ b/libs/gst/helpers/Makefile.am
@@ -5,6 +5,15 @@ gst_plugin_scanner_SOURCES = gst-plugin-scanner.c
gst_plugin_scanner_CFLAGS = $(GST_OBJ_CFLAGS)
gst_plugin_scanner_LDADD = $(GST_OBJ_LIBS)
+Android.mk: Makefile.am
+ androgenizer -:PROJECT gstreamer -:EXECUTABLE gst-plugin-scanner -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(gst_plugin_scanner_SOURCES) \
+ -:CFLAGS $(gst_plugin_scanner_CFLAGS) \
+ -:LDFLAGS $(gst_plugin_scanner_LDADD) \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ > $@
+
# clean out the old one to make sure everything is udpated correctly
# remove again after release
CLEANFILES = plugin-scanner