summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0bc4f730..2e7f191b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@ noinst_PROGRAMS = \
simple-decoder \
test-decode \
test-display \
+ test-filter \
test-surfaces \
test-windows \
test-subpicture \
@@ -85,6 +86,11 @@ test_display_SOURCES = test-display.c
test_display_CFLAGS = $(TEST_CFLAGS)
test_display_LDADD = libutils.la $(TEST_LIBS)
+test_filter_SOURCES = test-filter.c
+test_filter_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+test_filter_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS) \
+ $(top_builddir)/gst-libs/gst/video/libgstvaapi-videoutils.la
+
test_surfaces_SOURCES = test-surfaces.c
test_surfaces_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
test_surfaces_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS) \