summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
new file mode 100644
index 00000000..bad55d50
--- /dev/null
+++ b/ext/Makefile.am
@@ -0,0 +1,29 @@
+EXTRA_DIST =
+
+codecparsers_srcdir = \
+ $(top_srcdir)/ext/codecparsers/gst-libs/gst/codecparsers
+
+codecparsers_source_c = \
+ gsth264parser.c \
+ gstjpegparser.c \
+ gstmpeg4parser.c \
+ gstmpegvideoparser.c \
+ gstvc1parser.c \
+ parserutils.c \
+ $(NULL)
+
+EXTRA_DIST += $(codecparsers_source_c:%.c=$(codecparsers_srcdir)/%.c)
+
+codecparsers_source_h = \
+ gsth264parser.h \
+ gstjpegparser.h \
+ gstmpeg4parser.h \
+ gstmpegvideoparser.h \
+ gstvc1parser.h \
+ parserutils.h \
+ $(NULL)
+
+EXTRA_DIST += $(codecparsers_source_h:%.h=$(codecparsers_srcdir)/%.h)
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = Makefile.in