summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f737299..99d568d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,15 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = gst-libs pkgconfig sys tests
+SUBDIRS = debian gst-libs pkgconfig sys tests
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = \
aclocal.m4 compile config.guess config.sub \
configure depcomp install-sh ltmain.sh \
Makefile.in missing config.h.in
+
+deb: dist
+ -mkdir -p debian-build
+ cd debian-build && \
+ tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
+ cd $(PACKAGE)-$(VERSION) && dpkg-buildpackage -rfakeroot -uc -us