summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorZhao Halley <halley.zhao@intel.com>2013-07-08 16:54:55 +0800
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2013-08-23 19:00:38 +0200
commitd7cc1374ed103217bc5a5661167a8c5302e021ea (patch)
treec6b109d18858109b52d6025b5e18f074f053b943 /tests/Makefile.am
parent944a7bd077fdc77c7383f975af45f0db262bff77 (diff)
tests: add initial test for video processing.
Add minimal test case for video processing: scaling and color format conversion. Signed-off-by: Gwenole Beauchesne <gwenole.beauchesne@intel.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0bc4f730..2e7f191b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,6 +2,7 @@ noinst_PROGRAMS = \
simple-decoder \
test-decode \
test-display \
+ test-filter \
test-surfaces \
test-windows \
test-subpicture \
@@ -85,6 +86,11 @@ test_display_SOURCES = test-display.c
test_display_CFLAGS = $(TEST_CFLAGS)
test_display_LDADD = libutils.la $(TEST_LIBS)
+test_filter_SOURCES = test-filter.c
+test_filter_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
+test_filter_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS) \
+ $(top_builddir)/gst-libs/gst/video/libgstvaapi-videoutils.la
+
test_surfaces_SOURCES = test-surfaces.c
test_surfaces_CFLAGS = $(TEST_CFLAGS) $(GST_VIDEO_CFLAGS)
test_surfaces_LDADD = libutils.la $(TEST_LIBS) $(GST_VIDEO_LIBS) \