summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2019-10-11 17:13:34 +0200
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2019-10-11 17:13:34 +0200
commitf80dee40c8b688f21173094e2853e080d1575449 (patch)
treee4459c9193d2eed942028019f411bf3008e13a63 /meson.build
parent600aba57cfe91ea991c41f75f7ad347621ec4f5a (diff)
build: halt meson configuration if no renderer API
We should halt meson configuration if there is no render API installed (either DRM, Wayland or X11). That behavior was already in autotools but missed in meson. This patch brings it back. Fixes: #196
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 227bcf92..4ef68813 100644
--- a/meson.build
+++ b/meson.build
@@ -115,6 +115,10 @@ USE_GLX = libva_x11_dep.found() and x11_dep.found() and gl_dep.found() and libdl
USE_WAYLAND = libva_wayland_dep.found() and wayland_client_dep.found() and wayland_protocols_dep.found() and wayland_scanner_bin.found() and get_option('with_wayland') != 'no'
USE_X11 = libva_x11_dep.found() and x11_dep.found() and get_option('with_x11') != 'no'
+if not (USE_DRM or USE_X11 or USE_EGL or USE_GLX or USE_WAYLAND)
+ error('No renderer API found (it is requried either DRM, X11 and/or WAYLAND)')
+endif
+
driverdir = libva_dep.get_pkgconfig_variable('driverdir')
if driverdir == ''
driverdir = '@0@/@1@/@2@'.format(get_option('prefix'), get_option('libdir'), 'dri')