summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorHe Junyan <junyan.he@hotmail.com>2020-02-22 16:06:13 +0800
committerGStreamer Merge Bot <gitlab-merge-bot@gstreamer-foundation.org>2020-02-22 12:59:13 +0000
commit3ff51a6e5232ce529777ce5856c2afc12526a9c2 (patch)
tree7ef64cca7aa824d8d62f301cc23c0a61d11dc5aa /meson.build
parentb7af4205aa26a1486dd64f39812ae1ad2dd72d63 (diff)
build: let the build fail if none if X11, wayland or drm.
In fact, gst_vaapi_create_test_display only test x11, wayland and drm, no glx and egl entries. So if none of them is enabled, no vaapi element can be detected.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ce4403f1..3a6e9340 100644
--- a/meson.build
+++ b/meson.build
@@ -117,7 +117,7 @@ USE_WAYLAND = libva_wayland_dep.found() and wayland_client_dep.found() and wayla
USE_X11 = libva_x11_dep.found() and x11_dep.found() and get_option('with_x11') != 'no'
USE_GLX = libva_x11_dep.found() and x11_dep.found() and gl_dep.found() and libdl_dep.found() and get_option('with_glx') != 'no' and USE_X11
-if not (USE_DRM or USE_X11 or USE_EGL or USE_GLX or USE_WAYLAND)
+if not (USE_DRM or USE_X11 or USE_WAYLAND)
error('No renderer API found (it is requried either DRM, X11 and/or WAYLAND)')
endif