summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorHaihao Xiang <haihao.xiang@intel.com>2018-12-26 14:36:23 +0800
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2019-01-07 17:46:42 +0000
commit5b447753da350c2ad71ca4334b864cda60715ccf (patch)
tree1d97c862d50bb56973e63db05566ab94f5c5922d /meson.build
parent77bb3424dc82d3cdc94ce52029b7d9b0b0d1ab69 (diff)
meson: build h264 fei encoder if possible
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 070387cd..06e93cf5 100644
--- a/meson.build
+++ b/meson.build
@@ -86,6 +86,7 @@ endif
USE_ENCODERS = get_option('with_encoders') != 'no'
USE_VP9_ENCODER = USE_ENCODERS and cc.has_header('va/va_enc_vp9.h', dependencies: libva_dep, prefix: '#include <va/va.h>')
+USE_H264_FEI_ENCODER = USE_ENCODERS and cc.has_header('va/va_fei_h264.h', dependencies: libva_dep, prefix: '#include <va/va.h>')
USE_DRM = libva_drm_dep.found() and libdrm_dep.found() and libudev_dep.found() and get_option('with_drm') != 'no'
USE_EGL = gmodule_dep.found() and egl_dep.found() and GLES_VERSION_MASK != 0 and get_option('with_egl') != 'no'
@@ -112,6 +113,7 @@ cdata.set10('USE_EGL', USE_EGL)
cdata.set10('USE_ENCODERS', USE_ENCODERS)
cdata.set10('USE_GLX', USE_GLX)
cdata.set10('USE_VP9_ENCODER', USE_VP9_ENCODER)
+cdata.set10('USE_H264_FEI_ENCODER', USE_H264_FEI_ENCODER)
cdata.set10('USE_WAYLAND', USE_WAYLAND)
cdata.set10('USE_X11', USE_X11)
cdata.set10('HAVE_XKBLIB', cc.has_header('X11/XKBlib.h', dependencies: x11_dep))