summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-11-02 16:50:47 +0100
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2018-11-05 13:46:17 +0100
commit254eb9507f5e3c51552bfdf6c4b97650e847d55a (patch)
tree02a3e2fb7d05211023620b09bcc340d5fe57bfa8 /meson.build
parent5171a3d5b1b3ebe7a26c8b835edeb922186f374a (diff)
build: meson: build examples
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9af89604..f948bb9c 100644
--- a/meson.build
+++ b/meson.build
@@ -68,6 +68,9 @@ x11_dep = dependency('x11', required: false)
xrandr_dep = dependency('xrandr', required: false)
xrender_dep = dependency('xrender', required: false)
+# some of the examples can use GTK+-3
+gtk_dep = dependency('gtk+-3.0', version : '>= 3.10', required : get_option('examples'))
+
GLES_VERSION_MASK = gl_dep.found() ? 1 : 0
if glesv2_dep.found()
if (cc.has_header('GLES2/gl2.h', dependencies: glesv2_dep) and
@@ -182,7 +185,9 @@ libsinc = include_directories('gst-libs')
subdir('gst-libs')
subdir('gst')
-#subdir('tests')
+if not get_option('examples').disabled()
+ subdir('tests')
+endif
python3 = import('python3').find_python()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')