summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-12-07 18:40:35 +0100
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-12-07 19:05:50 +0100
commitf35a7f8fb0e3862028e5467791bfb17d47e96182 (patch)
tree3c4c3ce2bfd67aed73b28335cefbdf49a47630a9 /configure.ac
parent820c52f9533b57fc7ceac74b26bb1bdc4a0d4cc4 (diff)
Add new GStreamer version check utilities.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 808fa632..9baa50c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,14 @@ PKG_CHECK_MODULES([GST_PLUGINS_BASE],
AC_SUBST(GST_PLUGINS_BASE_CFLAGS)
AC_SUBST(GST_PLUGINS_BASE_LIBS)
+V=`$PKG_CONFIG --modversion gstreamer-plugins-base-$GST_MAJORMINOR`
+GST_PLUGINS_BASE_MAJOR_VERSION=`echo "$V" | cut -d'.' -f1`
+GST_PLUGINS_BASE_MINOR_VERSION=`echo "$V" | cut -d'.' -f2`
+GST_PLUGINS_BASE_MICRO_VERSION=`echo "$V" | cut -d'.' -f3`
+AC_SUBST(GST_PLUGINS_BASE_MAJOR_VERSION)
+AC_SUBST(GST_PLUGINS_BASE_MINOR_VERSION)
+AC_SUBST(GST_PLUGINS_BASE_MICRO_VERSION)
+
dnl Check for GStreamer base
PKG_CHECK_MODULES([GST_BASE],
[gstreamer-base-$GST_MAJORMINOR >= $GST_VERSION_REQUIRED]
@@ -328,6 +336,7 @@ debian.upstream/libgstvaapi-glx.install.in
docs/reference/plugins/plugins-docs.xml
gst-libs/Makefile
gst-libs/gst/Makefile
+ gst-libs/gst/gstutils_version.h
gst-libs/gst/vaapi/Makefile
pkgconfig/Makefile
pkgconfig/gstreamer-vaapi-$GST_MAJORMINOR.pc:\