summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2017-04-27 22:55:27 -0700
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2017-05-02 17:03:30 +0200
commit33888bf534400d3ea3ad7f4c9041ed835076fcc0 (patch)
tree13e541d30fc8da091f18095a50cd3cd6b44b8349 /configure.ac
parent8cbe03599a4f27c2001380e2ec150c4f4267a9cf (diff)
build: Require libva < 0.99.0
libva >= 0.99.0 is not currently supported by gstreamer-vaapi, so fail to configure instead of failing late in the build. This libva is bundled in msdk[1] and it is ahead in time with respect the official and open source libva[2]. GStreamer-VAAPI only supports the latter for now. 1. https://software.intel.com/en-us/media-sdk/download 2. https://github.com/01org/libva/ https://bugzilla.gnome.org/show_bug.cgi?id=781866
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 73620615..31281591 100644
--- a/configure.ac
+++ b/configure.ac
@@ -484,7 +484,7 @@ dnl -- VA-API --
dnl ---------------------------------------------------------------------------
dnl Core API
-PKG_CHECK_MODULES([LIBVA], [libva >= $VAAPI_REQ])
+PKG_CHECK_MODULES([LIBVA], [libva >= $VAAPI_REQ libva < 0.99.0])
VA_VERSION_STR=`$PKG_CONFIG --modversion libva`
VA_DRIVERS_PATH=`$PKG_CONFIG --variable=driverdir libva`
AC_DEFINE_UNQUOTED([VA_DRIVERS_PATH], ["$VA_DRIVERS_PATH"],