summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2016-01-25 12:40:49 +0000
committerTim-Philipp Müller <tim@centricular.com>2016-01-25 13:58:14 +0000
commit71f2f765f673cd5b791a9f30dd757fd32d6b0f05 (patch)
tree77bf4003c697b9abab7b8b072d615e98ae4af087 /Makefile.am
parent1c722efe54b89a0c31840108ace71661aaca969f (diff)
Remove debian.upstream packaging
https://bugzilla.gnome.org/show_bug.cgi?id=759192
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 1 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index b10a0c72..1f2bcdb4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = debian.upstream gst-libs gst tests docs
+SUBDIRS = gst-libs gst tests docs
# Extra clean files so that maintainer-clean removes *everything*
MAINTAINERCLEANFILES = \
@@ -12,18 +12,4 @@ MAINTAINERCLEANFILES = \
$(srcdir)/gtk-doc.make $(srcdir)/m4/gtk-doc.m4 \
$(NULL)
-DEB_BUILDDIR = debian.build
-
-deb:
- dpkg-buildpackage -rfakeroot -uc -us
-
-deb.upstream: dist-bzip2
- -mkdir -p $(DEB_BUILDDIR)
- cd $(DEB_BUILDDIR) && \
- rm -rf $(PACKAGE)-$(VERSION) && \
- tar jxvf ../$(PACKAGE)-$(VERSION).tar.bz2 && \
- cd $(PACKAGE)-$(VERSION) && \
- $(LN_S) debian.upstream debian && \
- $(MAKE) deb -f Makefile.am
-
-include $(top_srcdir)/git.mk