summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-09-28 17:39:43 +0200
committerGwenole Beauchesne <gwenole.beauchesne@intel.com>2012-09-28 17:54:50 +0200
commit43ba2f1940005289ec7d0c26c434f0465734ce33 (patch)
tree1af86a0fd41819aa65bec046f7c47e3a2cca6c82
parentdd915c15c83f46a9eec376ac35fd3f816477ab10 (diff)
debian: fix Wayland build dependencies.
-rw-r--r--configure.ac8
-rw-r--r--debian.upstream/control.in2
2 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3b77e3c4..7f4f8ad2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,9 @@ m4_define([gst_plugins_bad_micro_version], [22])
m4_define([gst_plugins_bad_version],
[gst_plugins_bad_major_version.gst_plugins_bad_minor_version.gst_plugins_bad_micro_version])
+# Wayland minimum version number
+m4_define([wayland_api_version], [0.95.0])
+
# VA-API minimum version number
m4_define([va_api_version], [0.30.4])
m4_define([va_api_drm_version], [0.33.0])
@@ -83,6 +86,9 @@ AC_SUBST(GST_VAAPI_MAJOR_VERSION)
LIBVA_PACKAGE_VERSION=libva_x11_package_version
AC_SUBST(LIBVA_PACKAGE_VERSION)
+WAYLAND_API_VERSION=wayland_api_version
+AC_SUBST(WAYLAND_API_VERSION)
+
dnl Versions for GStreamer and plugins-base
GST_MAJORMINOR=gst_major_minor_version
GST_VERSION_REQUIRED=gst_version
@@ -370,7 +376,7 @@ fi
dnl Check for Wayland
USE_WAYLAND=0
if test "$enable_wayland" = "yes"; then
- PKG_CHECK_MODULES(WAYLAND, [wayland-client],
+ PKG_CHECK_MODULES(WAYLAND, [wayland-client >= wayland_api_version],
[USE_WAYLAND=1], [USE_WAYLAND=0])
if test $USE_WAYLAND -eq 1; then
diff --git a/debian.upstream/control.in b/debian.upstream/control.in
index c40d5b07..661856c1 100644
--- a/debian.upstream/control.in
+++ b/debian.upstream/control.in
@@ -10,7 +10,7 @@ Build-Depends: debhelper (>= 5),
@USE_DRM_TRUE@ libdrm-dev, libudev-dev,
@USE_X11_TRUE@ libx11-dev, libxrandr-dev,
@USE_GLX_TRUE@ libgl-dev,
-@USE_WAYLAND_TRUE@ libwayland-dev,
+@USE_WAYLAND_TRUE@ libwayland-dev (>= @WAYLAND_API_VERSION@),
libva-dev (>= @LIBVA_PACKAGE_VERSION@)
Build-Depends-Indep: gtk-doc-tools (>= @GTKDOC_VERSION@)
Standards-Version: 3.7.2