summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50fe7a4..c61282f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,7 @@ AS_LIBTOOL(GST, 0, 0, 0)
dnl *** required versions of GStreamer stuff ***
GST_REQ=0.11.0
GSTPB_REQ=0.11.0
+GSTPG_REQ=0.11.0
dnl *** autotools stuff ****
@@ -142,6 +143,11 @@ GSTPB_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-base-$GST_API_VERSION --variabl
AC_SUBST(GSTPB_PLUGINS_DIR)
AC_MSG_NOTICE(Using GStreamer Base Plugins in $GSTPB_PLUGINS_DIR)
+AG_GST_CHECK_GST_PLUGINS_GOOD($GST_API_VERSION, [$GSTPG_REQ], [yes])
+GSTPG_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-good-$GST_API_VERSION --variable pluginsdir`
+AC_SUBST(GSTPG_PLUGINS_DIR)
+AC_MSG_NOTICE(Using GStreamer Good Plugins in $GSTPG_PLUGINS_DIR)
+
AG_GST_CHECK_GST_CHECK($GST_API_VERSION, [$GST_REQ], no)
dnl FIXME: get rid of this by making sure gstreamer-check brings it in
@@ -250,6 +256,7 @@ gst/Makefile
gst/rtsp-server/Makefile
examples/Makefile
tests/Makefile
+tests/check/Makefile
bindings/Makefile
bindings/vala/Makefile
pkgconfig/Makefile