summaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 07a0f12c..6c5bf419 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -28,6 +28,17 @@ if not hotdoc_p.found()
subdir_done()
endif
+hotdoc_req = '>= 0.11.0'
+hotdoc_version = run_command(hotdoc_p, '--version').stdout()
+if not hotdoc_version.version_compare(hotdoc_req)
+ if get_option('doc').enabled()
+ error('Hotdoc version @0@ not found, got @1@'.format(hotdoc_req, hotdoc_version))
+ else
+ message('Hotdoc version @0@ not found, got @1@'.format(hotdoc_req, hotdoc_version))
+ subdir_done()
+ endif
+endif
+
hotdoc = import('hotdoc')
foreach extension: required_hotdoc_extensions
if not hotdoc.has_extensions(extension)