summaryrefslogtreecommitdiff
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martinpitt@gnome.org>2013-01-15 15:18:04 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2013-01-16 11:14:59 +0000
commit62c608ada2c665b089c46ad2389877567e0b0ff7 (patch)
tree5f09f80335603e5d2b5b766da9a69607b0adf7cb /tests/check/Makefile.am
parent515028a2fb9b6add39e672c4ac56ad3c4186ad3b (diff)
tests: use _1_0 variants for the various registry variables
These override the variants without version suffix. Makes 'make check' work properly in environments that set the suffixed variant for 1.0, such as jhbuild.
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 6bd51d89..2cb6b816 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -3,12 +3,12 @@ include $(top_srcdir)/common/check.mak
CHECK_REGISTRY = $(top_builddir)/tests/check/test-registry.reg
REGISTRY_ENVIRONMENT = \
- GST_REGISTRY=$(CHECK_REGISTRY)
+ GST_REGISTRY_1_0=$(CHECK_REGISTRY)
TESTS_ENVIRONMENT = \
$(REGISTRY_ENVIRONMENT) \
- GST_PLUGIN_SYSTEM_PATH= \
- GST_PLUGIN_PATH=$(top_builddir)/gst:$(top_builddir)/ext:$(top_builddir)/sys:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR) \
+ GST_PLUGIN_SYSTEM_PATH_1_0= \
+ GST_PLUGIN_PATH_1_0=$(top_builddir)/gst:$(top_builddir)/ext:$(top_builddir)/sys:$(GSTPB_PLUGINS_DIR):$(GST_PLUGINS_DIR) \
GST_PLUGIN_LOADING_WHITELIST="gstreamer@$(GST_PLUGINS_DIR):gst-plugins-base@$(GSTPB_PLUGINS_DIR):gst-plugins-ugly@$(top_builddir)" \
GST_STATE_IGNORE_ELEMENTS="siddec dvdreadsrc cdiocddasrc"