summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-09-19 12:00:32 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-09-19 12:00:32 +0100
commit6c37b359eefebe634e7fb467173a6cac2407e2cc (patch)
tree23ce5daffb38f743ece1c28eb2fcb6a38c3a6f47 /meson.build
parentb71b9ec934ce0117119d6db13ed7a70069e16db8 (diff)
meson: add glib-checks option to disable API guards and such
We want this enabled by default, also in releases, but people may want to disable this for performance-critical workloads or on embedded devices.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9013477d..7f786e91 100644
--- a/meson.build
+++ b/meson.build
@@ -230,6 +230,12 @@ if glib_asserts.disabled() or (glib_asserts.auto() and not gst_version_is_dev)
add_project_arguments('-DG_DISABLE_ASSERT', language: 'c')
endif
+glib_checks = get_option('glib-checks')
+if glib_checks.disabled() or (glib_checks.auto() and not gst_version_is_dev)
+ message('Disabling GLib checks')
+ add_project_arguments('-DG_DISABLE_CHECKS', language: 'c')
+endif
+
presetdir = join_paths(get_option('datadir'), 'gstreamer-' + api_version, 'presets')
pkgconfig = import('pkgconfig')