summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 19:32:00 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2018-05-05 19:32:00 +0530
commitac90718ffc102f6411be271f0cdc222740ab28f6 (patch)
tree469665fee53fb9238613a1d2630929b4bcb67f06 /meson.build
parentc789277ec065eb2ac2bcb77ab2f5329caf3fe9ab (diff)
meson: Update option names to omit disable_ and with- prefixes
Also yield common options to the outer project (gst-build in our case) so that they don't have to be set manually.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index cc6632f9..daad19c3 100644
--- a/meson.build
+++ b/meson.build
@@ -120,7 +120,7 @@ cdata.set('GETTEXT_PACKAGE', '"gst-plugins-ugly-1.0"')
cdata.set('GST_LICENSE', '"LGPL"')
# GStreamer package name and origin url
-gst_package_name = get_option('with-package-name')
+gst_package_name = get_option('package-name')
if gst_package_name == ''
if gst_version_nano == 0
gst_package_name = 'GStreamer Ugly Plug-ins source release'
@@ -131,7 +131,7 @@ if gst_package_name == ''
endif
endif
cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
-cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
+cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('package-origin'))
# Mandatory GST deps
gst_dep = dependency('gstreamer-1.0', version : gst_req,
@@ -181,7 +181,7 @@ configinc = include_directories('.')
libsinc = include_directories('gst-libs')
if gst_dep.type_name() == 'internal'
- gst_debug_disabled = subproject('gstreamer').get_variable('disable_gst_debug')
+ gst_debug_disabled = not subproject('gstreamer').get_variable('gst_debug')
else
# We can't check that in the case of subprojects as we won't
# be able to build against an internal dependency (which is not built yet)