summaryrefslogtreecommitdiff
path: root/ext/x264/meson.build
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2016-11-11 14:15:17 +0200
committerSebastian Dröge <sebastian@centricular.com>2016-11-14 18:26:04 +0200
commit7bf576b238c0baec0051245d78ac5a1dfca32b92 (patch)
tree3d65460af78ff82199d927ca66c81c875952d753 /ext/x264/meson.build
parentb96515449c2659f2b26b545cc7ddfe39ae55ee83 (diff)
x264enc: Add configure parameter to specify additional x264 libraries with e.g. different depth configuration
x264 has to be compiled specifically for a target bit depth. Distributions currently ship various libraries in their packages, with different bit depths. This change now allows to provide them all at configure time and have the x264enc element dynamically switch between them based on the bit depth of the input format. https://bugzilla.gnome.org/show_bug.cgi?id=763297
Diffstat (limited to 'ext/x264/meson.build')
-rw-r--r--ext/x264/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/ext/x264/meson.build b/ext/x264/meson.build
index 3aead3bd..20e5866d 100644
--- a/ext/x264/meson.build
+++ b/ext/x264/meson.build
@@ -5,9 +5,15 @@ x264_sources = [
x264_dep = dependency('x264', required : false)
if x264_dep.found()
+ x264_libraries = get_option('x264_libraries')
+ x264_args = []
+ if x264_libraries != ''
+ x264_args += ['-DHAVE_X264_ADDITIONAL_LIBRARIES="@0@"'.format(x264_libraries)]
+ endif
+
gstx264 = library('gstx264',
x264_sources,
- c_args : ugly_args,
+ c_args : ugly_args + x264_args,
include_directories : [configinc],
dependencies : [gstbase_dep, gstvideo_dep, gstpbutils_dep, x264_dep],
install : true,