summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
committerDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
commit287ccb5f971689792a48c154e31a9adcf6e891b1 (patch)
tree64a2170bad7e1300c3d13adcb608435295bf021f /ext/Makefile.am
parent0ae0b53c42954a02c5189ec254743667ab2f0652 (diff)
configure.ac: add audioresample and cairo plugins. Remove
Original commit message from CVS: * configure.ac: add audioresample and cairo plugins. Remove HAVE_MMX stuff, because it's not used. * ext/Makefile.am: same * ext/audioresample/Makefile.am: You are not ready for an audio resampling element based on audioresample. * ext/audioresample/gstaudioresample.c: * ext/audioresample/gstaudioresample.h: * ext/cairo/Makefile.am: You are not ready for overlay elements based on cairo. Don't look too closely, these elements kinda suck right now. * ext/cairo/gstcairo.c: new * ext/cairo/gsttextoverlay.c: new * ext/cairo/gsttextoverlay.h: new * ext/cairo/gsttimeoverlay.c: new * ext/cairo/gsttimeoverlay.h: new * gst-libs/gst/media-info/media-info-priv.h: fix compile problem with compilers that don't support variadic macros.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 42faa62c..934e0a2c 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -34,6 +34,18 @@ else
AUDIOFILE_DIR=
endif
+if USE_AUDIORESAMPLE
+AUDIORESAMPLE_DIR=audioresample
+else
+AUDIORESAMPLE_DIR=
+endif
+
+if USE_CAIRO
+CAIRO_DIR=cairo
+else
+CAIRO_DIR=
+endif
+
if USE_CDAUDIO
CDAUDIO_DIR=cdaudio
else
@@ -383,6 +395,8 @@ SUBDIRS=\
$(ARTS_DIR) \
$(ARTSC_DIR) \
$(AUDIOFILE_DIR) \
+ $(AUDIORESAMPLE_DIR) \
+ $(CAIRO_DIR) \
$(CDAUDIO_DIR) \
$(CDPARANOIA_DIR) \
$(DIRAC_DIR) \
@@ -446,6 +460,8 @@ DIST_SUBDIRS=\
arts \
artsd \
audiofile \
+ audioresample \
+ cairo \
cdaudio \
cdparanoia \
dirac \