summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-06-05 19:25:54 +0100
committerJan Schmidt <thaytan@noraisin.net>2009-06-05 19:25:54 +0100
commit5e176f4b0c3795d6b403fbb8dd5a040f2e9c1a18 (patch)
tree91eca22552459487a74e03fed12561b59cc6293f /configure.ac
parent0823e9fa148375a5215f820a4a036ef952c50b2d (diff)
Moved 'x264enc' from -bad to -ugly
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3579b64f..b9cefe8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -377,6 +377,29 @@ AG_GST_CHECK_FEATURE(TWOLAME, [twolame], twolame, [
AC_SUBST(TWOLAME_LIBS)
])
+dnl *** x264 (MPEG-4 part 10/h.264/AVC encoder) ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_X264, true)
+AG_GST_CHECK_FEATURE(X264, [x264 plug-in], x264, [
+ AG_GST_CHECK_LIBHEADER(X264, x264, x264_nal_encode, -lm, x264.h,
+ AC_MSG_CHECKING([for uptodate x264 API version])
+ dnl _stdint not yet generated, so no compiling
+ AC_TRY_CPP([
+ #include <x264.h>
+ #if X264_BUILD < 55
+ #error "x264 build too old"
+ #endif
+ ], [
+ AC_MSG_RESULT(yes)
+ X264_LIBS="$LDFLAGS -lx264 -lm"
+ X264_CFLAGS="$CFLAGS"
+ AC_SUBST(X264_LIBS)
+ AC_SUBST(X264_CFLAGS)
+ ], [
+ AC_MSG_RESULT(no)
+ HAVE_X264=no
+ ]))
+])
+
else
dnl not building plugins with external dependencies,
@@ -393,6 +416,7 @@ AM_CONDITIONAL(USE_MAD, false)
AM_CONDITIONAL(USE_MPEG2DEC, false)
AM_CONDITIONAL(USE_SIDPLAY, false)
AM_CONDITIONAL(USE_TWOLAME, false)
+AM_CONDITIONAL(USE_X264, false)
fi dnl of EXT plugins
@@ -479,6 +503,7 @@ ext/mad/Makefile
ext/mpeg2dec/Makefile
ext/sidplay/Makefile
ext/twolame/Makefile
+ext/x264/Makefile
docs/Makefile
docs/plugins/Makefile
docs/version.entities