summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-07-02 10:02:13 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-07-02 10:02:13 +0000
commita033f371d430de5dd50887b34eafdccd15413e14 (patch)
tree9f8bc41194818f8063cee1fa4083ef040af243f5 /Makefile.am
parentd538c8991857f37bd05e243bbd7857ac30677cf3 (diff)
clean up install/dist problem
Original commit message from CVS: clean up install/dist problem
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d773bc68..e20dd34a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,9 +48,13 @@ DISTCLEANFILES=_stdint.h
# this in turn ensures that distcheck fails for missing .list files which is currently
# shadowed when the corresponding .c and .h files are included.
distcheck-hook:
- test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
+ @test "x" = "x`find $(distdir) -name \*-enumtypes.[ch]`" && \
test "x" = "x`find $(distdir) -name \*-marshal.[ch]`" || \
- ( $(ECHO) "*** Still leftover enumtypes or marshal files in the tarball. Please make sure those are not disted." && false )
+ ( $(ECHO) "*** Leftover enumtypes or marshal files in the tarball." && \
+ $(ECHO) "*** Make sure the following files are not disted:" && \
+ find $(distdir) -name \*-enumtypes.[ch] && \
+ find $(distdir) -name \*-marshal.[ch] && \
+ false )
include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak