summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2006-04-10 14:47:11 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2006-04-10 14:47:11 +0000
commit566525df79afb4cc2345871774e00f726440b1bb (patch)
treea2b682a270e88569bcebdbce95e003d97a13ed58 /Makefile.am
parentc201d235e04da2b7c9ebd620f61f3b4be615f733 (diff)
add test for amrnbenc, enable test infrastructure, and fix a leak
Original commit message from CVS: add test for amrnbenc, enable test infrastructure, and fix a leak * common/check.mak: allow for specifying more than one suppressions file in SUPPRESSIONS * Makefile.am: * tests/Makefile.am: * tests/check/.cvsignore: * tests/check/Makefile.am: * tests/check/elements/.cvsignore: * configure.ac: add tests/check * tests/check/gst-plugins-ugly.supp: add suppressions for libs used by -ugly * tests/check/elements/amrnbenc.c: (buffer_new), (buffer_unref), (setup_amrnbenc), (cleanup_amrnbenc), (push_data), (GST_START_TEST), (amrnbenc_suite), (main): add a simple test for encoding amr * ext/amrnb/amrnbenc.c: (gst_amrnbenc_init): fix pad template leaks
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index fed20f5c..795cc6e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
SUBDIRS = \
- gst ext docs m4 common
+ gst ext docs m4 tests common
EXTRA_DIST = \
gst-plugins-ugly.spec depcomp \
@@ -16,7 +16,12 @@ include $(top_srcdir)/common/release.mak
include $(top_srcdir)/common/po.mak
check-valgrind:
- @true
+ cd tests/check && make check-valgrind
+if HAVE_CHECK
check-torture:
- @true
+ cd tests/check && make torture
+else
+check-torture:
+ true
+endif